<!DOCTYPE html> <html itemscope itemtype="http://schema.org/ItemList" class=" story "> <html> <head> <link rel="shortcut icon" href="/pb/resources/favicon.ico" type="image/x-icon"/> <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> <meta charset="UTF-8"/> <meta id="viewport" name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=yes, minimum-scale=0.5, maximum-scale=2.0"/> <meta name="keywords" content=""/> <meta itemprop="description" name="description" value="Maryland’s quarterbacks have really, really struggled to stay healthy."/> <meta name="news_keywords" content=""/> <meta name="twitter:site" value="@theDBK"/> <meta name="twitter:card" content="summary_large_image"> <meta property="og:description" content="Maryland’s quarterbacks have really, really struggled to stay healthy."/> <meta property="og:type" content="article"/> <meta property="og:site_name" content="The Diamondback"/> <meta itemprop="image" property="og:image" content="https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/11/13001741/111216FBvsOSU_Rowe_mkm01.jpg"/> <meta property="og:title" content="Maryland football has had 15 quarterbacks since 2007. We ranked them all."/> <meta property="article:publisher" content="https://www.facebook.com/TheDiamondback"> <meta property="fb:app_id" content=""/> <meta property="og:url" content="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"/> <link rel="canonical" href="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"/> <title>Maryland football has had 15 quarterbacks since 2007. We ranked them all. - The Diamondback</title> <meta property="article:tag" content="c.j. brown"> <meta property="article:tag" content="Caleb Rowe"> <meta property="article:tag" content="chris turner"> <meta property="article:tag" content="danny o'brien"> <meta property="article:tag" content="kasim hill"> <meta property="article:tag" content="maryland football"> <meta property="article:tag" content="Perry Hills"> <meta property="article:tag" content="shawn petty"> <meta property="article:tag" content="Tyrrell Pigrome"> <meta property="article:section" content="Sports"> <meta property="article:section" content="Terps Watch"> <link href="/pb/gr/c/default/rbKOI52RYMmxwq/css/04327b3cee.css?_=ae923" rel="stylesheet"/> <link href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap.min.css" rel="stylesheet"/> <link href="/pb/gr/c/default/rbKOI52RYMmxwq/css/a4f27b03d9.css?_=ae923" rel="stylesheet"/> <link href="/pb/gr/p/default/rbKOI52RYMmxwq/style.css?_=8c911" rel="stylesheet"/> <script>var isMobile={Android:function(){return navigator.userAgent.match(/Android/i)?!0:!1},AndroidOld:function(){return navigator.userAgent.match(/Android 2.3.3/i)?!0:!1},AndroidTablet:function(){return navigator.userAgent.match(/Android/i)&&!navigator.userAgent.match(/Mobile/i)?!0:!1},Kindle:function(){return navigator.userAgent.match(/Kindle/i)?!0:!1},KindleFire:function(){return navigator.userAgent.match(/KFOT/i)?!0:!1},Silk:function(){return navigator.userAgent.match(/Silk/i)?!0:!1},BlackBerry:function(){return navigator.userAgent.match(/BlackBerry/i)?
!0:!1},iOS:function(){return navigator.userAgent.match(/iPhone|iPad|iPod/i)?!0:!1},iPhone:function(){return navigator.userAgent.match(/iPhone|iPod/i)?!0:!1},iPad:function(){return navigator.userAgent.match(/iPad/i)?!0:!1},Windows:function(){return navigator.userAgent.match(/IEMobile/i)?!0:!1},FirefoxOS:function(){return navigator.userAgent.match(/Mozilla/i)&&navigator.userAgent.match(/Mobile/i)?!0:!1},Retina:function(){return window.retina||1<window.devicePixelRatio?!0:!1},any:function(){return isMobile.Android()||
isMobile.Kindle()||isMobile.KindleFire()||isMobile.Silk()||isMobile.BlackBerry()||isMobile.iOS()||isMobile.Windows()||isMobile.FirefoxOS()},all:function(){return navigator.userAgent},tablet:function(){return isMobile.AndroidTablet()||isMobile.iPad()||isMobile.Kindle()||isMobile.KindleFire()||isMobile.Silk()}},mobile_browser=isMobile.any()?1:0,iphone_browser=isMobile.iPhone()?1:0,ipad_browser=isMobile.iPad()?1:0,android_browser=isMobile.Android()?1:0,android233_browser=isMobile.AndroidOld()?1:0,kindle_browser=
isMobile.Kindle()?1:0,retina_browser=isMobile.Retina()?1:0,mobile_tablet=isMobile.tablet()?1:0;</script> <script>
 if (typeof ad_meta_data == "undefined") {
   try {
     ad_meta_data = {
       platform:"pagebuilder",
       
     }
   } catch(e) {}
  }

  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script> <script>(function(a,e,f,g,b,c,d){a.GoogleAnalyticsObject=b;a[b]=a[b]||function(){(a[b].q=a[b].q||[]).push(arguments)};a[b].l=1*new Date;c=e.createElement(f);d=e.getElementsByTagName(f)[0];c.async=1;c.src=g;d.parentNode.insertBefore(c,d)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create","UA-68169216-3","auto",{name:"ARC_TRACKER"});ga("create","UA-34401991-1","auto",{name:"CLIENT_TRACKER"});ga("ARC_TRACKER.send","pageview");ga("CLIENT_TRACKER.send","pageview");</script> <script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20256262"});(function(){var a=document.createElement("script"),b=document.getElementsByTagName("script")[0];a.async=!0;a.src=("https:"==document.location.protocol?"https://sb[sb]":"http://b[b]")+".scorecardresearch.com/beacon.js";b.parentNode.insertBefore(a,b)})();</script> <noscript> <img src="http://b.scorecardresearch.com/p?c1=2&c2=20256262&cv=2.0&cj=1"/> </noscript> <script>var _sf_startpt=(new Date).getTime();</script> <script>var _qevents=_qevents||[];(function(){var a=document.createElement("script");a.src=("https:"==document.location.protocol?"https://secure":"http://edge")+".quantserve.com/quant.js";a.async=!0;a.type="text/javascript";var b=document.getElementsByTagName("script")[0];b.parentNode.insertBefore(a,b)})();_qevents.push({qacct:"p-devwm660sKDlc"});</script> <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script> </head> <body> <div id="fb-root"></div> <script>(function(a,b,c){var d=a.getElementsByTagName(b)[0];a.getElementById(c)||(a=a.createElement(b),a.id=c,a.src="//connect.facebook.net/en_US/all.js#xfbml\x3d1\x26amp;version\x3dv2.3",d.parentNode.insertBefore(a,d))})(document,"script","facebook-jssdk");</script> <div id="pb-root" class=""> <section id="top" class=""> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-header-nav" id="f0UnbKtomI4Fsq"> <div id="siteheader" class="headernav fixed socialRight"> <div class="row-one hidden-xs" style=""> <div class="masthead-image"> <h1 class="center title"> <span class="hidden">The Diamondback</span> <img class="center nav-hp-link" style="" src="https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/01/12220254/dbk-masthead.png" alt="The Diamondback"/> </h1> </div> <div class="social socialRight"> <div class="_toolclass_"><a href="https://facebook.com/thediamondback" target="_blank"><span class="fa social-fa fa-facebook-square"></span></a></div> <div class="_toolclass_"><a href="https://twitter.com/thedbk" target="_blank"><span class="fa social-fa fa-twitter"></span></a></div> <div class="_toolclass_"><a href="https://instagram.com/thedbk" target="_blank"><span class="fa social-fa fa-instagram"></span></a></div> <div class="_toolclass_"><a href="https://youtube.com/diamondbackvideo" target="_blank"><span class="fa social-fa fa-youtube-play"></span></a></div> </div> </div> <div class="row-two" style=""> <div class="left-burger-logo"> <span class="fa fa-bars burger"></span> <img class="scroll-logo nav-hp-link" src="https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/01/20175808/dbk.jpg" alt="The Diamondback"/> </div> <div class="center-nav"> <ul class="top-nav-list hidden-sm hidden-xs"> <a href="http://www.dbknews.com/category/news/"><li class="top-nav-list-item first">News</li></a> <a href="http://www.dbknews.com/category/sports/"><li class="top-nav-list-item">Sports</li></a> <a href="http://www.dbknews.com/category/opinion/"><li class="top-nav-list-item">Opinion</li></a> <a href="http://www.dbknews.com/category/diversions/"><li class="top-nav-list-item">Diversions</li></a> <a href="http://www.dbknews.com/category/special-projects/"><li class="top-nav-list-item">Special Projects</li></a> <a href="http://www.dbknews.com/classifieds/"><li class="top-nav-list-item">Classifieds</li></a> <a href="http://terphousing.com/"><li class="top-nav-list-item">Housing Guide</li></a> <a href="http://www.dbknews.com/about/"><li class="top-nav-list-item last">About Us</li></a> </ul> </div> <div class="search-container "> <form class="search" action="/search/" method="GET" onsubmit="javascript:this.action+=this.q.value.replace(/ /g,'+')" style=""> <input type="submit" class="submit"/> <button class="button search-icon fa fa-search"></button> <input type="text-field" class="text-field" id="q" name="q"/> </form> </div> </div> <div id="drawer"> <div id="slider-menu"> <div id="slider-menu-scroll"> <ul class="sections" id="slider-menu-nav-list"> <li id="mainnav-0" class="main-nav has-sub" data-subnav="0"> <a class="main-nav-item" href="http://www.dbknews.com/category/news/">News</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-1" class="main-nav has-sub" data-subnav="1"> <a class="main-nav-item" href="http://www.dbknews.com/category/sports/">Sports</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-2" class="main-nav has-sub" data-subnav="2"> <a class="main-nav-item" href="http://www.dbknews.com/category/opinion/">Opinion</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-3" class="main-nav has-sub" data-subnav="3"> <a class="main-nav-item" href="http://www.dbknews.com/category/diversions/">Diversions</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-4" class="main-nav has-sub" data-subnav="4"> <a class="main-nav-item" href="http://www.dbknews.com/category/special-projects/">Special Projects</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-5" class="main-nav" data-subnav="5"> <a class="main-nav-item" href="http://www.dbknews.com/classifieds/">Classifieds</a> </li> <li id="mainnav-6" class="main-nav" data-subnav="6"> <a class="main-nav-item" href="http://terphousing.com/">Housing Guide</a> </li> <li id="mainnav-7" class="main-nav has-sub" data-subnav="7"> <a class="main-nav-item" href="http://www.dbknews.com/about/">About Us</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li id="mainnav-8" class="main-nav" data-subnav="8"> <a class="main-nav-item" href="http://www.dbknews.com/category/multimedia/">Multimedia</a> </li> <li id="mainnav-9" class="main-nav" data-subnav="9"> <a class="main-nav-item" href="http://dbknews.com/orientation">Orientation Guide</a> </li> <li id="mainnav-10" class="main-nav has-sub" data-subnav="10"> <a class="main-nav-item" href="http://dbknews.com/SigmaAlphaMu">DBK Brand Connect</a> <i class="fa fa-angle-right main-nav-angle"></i> </li> <li class="copyright">&#169; 2017 The Diamondback</li> </ul> </div> </div> <div id="arrow-0" class="sub-nav-arrow"></div> <ul id="subnav-0" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/campus/">Campus</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/local/">Local</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/state/">State</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/nation/">Nation</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/world/">World</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/science-tech/">Science & Tech</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/news/dbk-context/">DBK + Context</a> </li> <li class="sub-nav-item"> <a href="http://salaryguide.diamondbacklab.com">Salary Guide</a> </li> </ul> <div id="arrow-1" class="sub-nav-arrow"></div> <ul id="subnav-1" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/football/">Football</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/mens-basketball/">Men's Basketball</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/mens-soccer/">Men's Soccer</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/womens-basketball/">Women's Basketball</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/field-hockey/">Field Hockey</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/volleyball/">Volleyball</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/womens-soccer/">Women's Soccer</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/sports/terps-watch/">Terps Watch</a> </li> </ul> <div id="arrow-2" class="sub-nav-arrow"></div> <ul id="subnav-2" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/opinion/staff-editorial/">Staff Editorial</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/opinion/column/">Column</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/opinion/guest-column/">Guest Column</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/opinion/an-inconvenient-youth/">An Inconvenient Youth</a> </li> </ul> <div id="arrow-3" class="sub-nav-arrow"></div> <ul id="subnav-3" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/arts/">Arts</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/books/">Books</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/campus-life/">Campus Life</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/culture/">Culture</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/fashion/">Fashion</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/food/">Food</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/gaming/">Gaming</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/movies/">Movies</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/music/">Music</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/category/diversions/tv/">TV</a> </li> </ul> <div id="arrow-4" class="sub-nav-arrow"></div> <ul id="subnav-4" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/protect-umd-demands/#">ProtectUMD</a> </li> <li class="sub-nav-item"> <a href="http://itsreal.diamondbacklab.com/">Sexual Assault Series</a> </li> <li class="sub-nav-item"> <a href="http://yearinreview.diamondbacklab.com">Year in Review</a> </li> </ul> <div id="arrow-7" class="sub-nav-arrow"></div> <ul id="subnav-7" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/find-a-paper/">Find A Paper</a> </li> <li class="sub-nav-item"> <a href="http://dbknews.com/subscribe">Subscribe</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/policies/">Policies</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/donate/">Donate</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/join-the-diamondback/">Jobs</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/awards/">Awards</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/advertising/">Advertising</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/contact-us/">Contact Us</a> </li> </ul> <div id="arrow-10" class="sub-nav-arrow"></div> <ul id="subnav-10" class="sub-nav"> <li class="sub-nav-item"> <a href="http://www.dbknews.com/umbc/">UMBC</a> </li> <li class="sub-nav-item"> <a href="http://dbknews.com/SigmaAlphaMu">Sigma Alpha Mu</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/student-loan-hero/">Student Loan Hero</a> </li> <li class="sub-nav-item"> <a href="http://dbknews.com/sponsoredcontent">carafem</a> </li> <li class="sub-nav-item"> <a href="http://www.dbknews.com/zabicolife/">ZABICOLife</a> </li> </ul> </div> </div> </div> <div class="pb-container"> </div> </section> <section id="main" class="container"> <div class="pb-container"> <div class="pb-layout-item pb-chain pb-c-default-chain" id="cReRCk2omI4Fsq"> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-ads-dfp-mobile-header-300x50" id="fKreoj2omI4Fsq"> <div id="Mobile_Header" class="mobile-fixed-header pb-ad-container-mobile mobile-header-300x50 border-bottom-hairline" data-ad-type="Mobile_Header" style="display: none;"></div> </div> <div class="wrapper clearfix col-lg-9 col-md-9 pb-feature pb-layout-item pb-f-ads-dfp-leaderboard-728x90 col-xs-9 col-sm-9" id="fYlXel1omI4Fsq"> <div id="Banner_A" class="pb-ad-container leaderboard-728x90 border-bottom-hairline" data-ad-type="Banner_A" style="display: none; "></div> </div> </div> <div class="wrapper clearfix col-lg-12 pb-feature pb-layout-item pb-f-article-header col-md-12 col-sm-12 col-xs-12" id="flgRX11omI4Fsq"> <div class="header-label"> <a href="http://www.dbknews.com/category/sports/terps-watch/">Terps Watch</a> </div> <div class="row"> <header class="article-header hed-first col-sm-12"> <figure> <h1>Maryland football has had 15 quarterbacks since 2007. We ranked them all.</h1> <span class="subheadline"></span> <img src="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/11/13001741/111216FBvsOSU_Rowe_mkm01.jpg&mode=crop&w=1200&q=99" class="image-lazy"/> <figcaption> <span class="caption credit col-sm-12 under-image ">Quarterback Caleb Rowe is tackled inches away from a touchdown in Maryland's 62-3 defeat to Ohio State University on Nov. 12, 2016 at Maryland Stadium. (Marquise McKine/The Diamondback)</span> </figcaption> </figure> </header> </div> </div> <div class="col-md-8 col-sm-12 col-xs-12 pb-layout-item pb-chain pb-c-list-chain" id="c0iHg27omI4Fsq"> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-article-slimline-byline" id="f0Gns7HomI4Fsq"> <div class="byline slimline thinline-border col-md-offset-1 col-md-10 col-sm-12 col-xs-12 line-up" style="padding-left:0;"> <div class="author-name-wrap"> <div class="author-name clearfix"> By <a class="author-name" href="/author/cannh" rel="author">Harrison Cann</a> </div> <script>window.twttr=function(a,c,d){var e=a.getElementsByTagName(c)[0],b=window.twttr||{};if(a.getElementById(d))return b;a=a.createElement(c);a.id=d;a.src="https://platform.twitter.com/widgets.js";e.parentNode.insertBefore(a,e);b._e=[];b.ready=function(a){b._e.push(a)};return b}(document,"script","twitter-wjs");</script> <a class="twitter-follow-button" data-show-count="false" href="https://twitter.com/cannh">Follow @</a> </div> <div class="publish"> Published 4:36 PM </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sharebar" id="fw744P1omI4Fsq"> <div id="sharebar_8054" class="sharebar-sticky-desktop sharebar-wrapper sharebar-sticky-mobile line-up" style="display: none;"> <div class="social-tools-wrapper"> <span class="social-tools-primary"> <div class="social-tools"> <a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Facebook'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Facebook'); window.open('https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F','share_facebook','width=658,height=354,scrollbars=no');" tabindex=_tbidx_> <div class="facebook tool first"><span class="hideText">Share on Facebook</span><span class="fa fa-facebook-square"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Twitter'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Twitter'); window.open('https://twitter.com/share?url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F&text=Maryland+football+has+had+15+quarterbacks+since+2007.+We+ranked+them+all.','share_twitter','width=550, height=350, scrollbars=no');" tabindex=_tbidx_> <div class="twitter tool"><span class="hideText">Share on Twitter</span><span class="fa fa-twitter"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'email'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'email'); window.location.href = 'mailto:?subject=Maryland%20football%20has%20had%2015%20quarterbacks%20since%202007.%20We%20ranked%20them%20all.&body=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F';" tabindex=_tbidx_> <div class="email tool"><span class="hideText">Share via Email</span><span class="fa fa-envelope"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Whatsapp'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Whatsapp'); window.location.href = 'whatsapp://send?text=Maryland%20football%20has%20had%2015%20quarterbacks%20since%202007.%20We%20ranked%20them%20all. - http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F';" tabindex=_tbidx_> <div class="whatsapp tool"><span class="hideText">Share on Whatsapp</span><span class="fa fa-whatsapp"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Tumblr'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Tumblr'); window.open('https://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F&name=Maryland+football+has+had+15+quarterbacks+since+2007.+We+ranked+them+all.&description=','share_tumblr','width=550,height=450,scrollbars=no');" tabindex=_tbidx_> <div class="tumblr tool"><span class="hideText">Share on Tumblr</span><span class="fa fa-tumblr"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'LinkedIn'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'LinkedIn'); window.open('https://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F&title=Maryland+football+has+had+15+quarterbacks+since+2007.+We+ranked+them+all.','share_linkedin','width=830,height=460,scrollbars=no');" tabindex=_tbidx_> <div class="linkedin tool"><span class="hideText">Share on LinkedIn</span><span class="fa fa-linkedin"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Google+'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Google+'); window.open('https://plus.google.com/share?url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F','share_google-plus','width=832,height=472,scrollbars=no');" tabindex=_tbidx_> <div class="google-plus tool"><span class="hideText">Share on Google Plus</span><span class="fa fa-google-plus"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Pinterest'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Pinterest'); window.open('//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F&media=&description=Maryland+football+has+had+15+quarterbacks+since+2007.+We+ranked+them+all.','share_linkedin','width=550,height=450,scrollbars=no');" tabindex=_tbidx_> <div class="pinterest tool"><span class="hideText">Share on Pinterest</span><span class="fa fa-pinterest"></span></div> </a><a class="sms-share-device unprocessed" onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'SMS'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'SMS'); window.location.href = 'sms://&body=Maryland%20football%20has%20had%2015%20quarterbacks%20since%202007.%20We%20ranked%20them%20all.%20-%20http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F%3Ftid=ss_sms'; return false;" tabindex=_tbidx_> <div class="sms tool"><span class="hideText">Share on SMS</span><span class="fa fa-commenting"></span></div> </a><a onclick="ga('CLIENT_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Print'); ga('ARC_TRACKER.send', 'event', 'Share Bar Click', 'click', 'Print'); window.print();" tabindex=_tbidx_> <div class="print tool last"><span class="hideText">Print article</span><span class="fa fa-print"></span></div> </a></div> </span> </div> </div> <div class="clear"></div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 pb-feature pb-layout-item pb-f-article-body col-sm-12 col-xs-12" id="f0TEdgHomI4Fsq"> <div id="article-body" class="article-body article-body-elements"> <div id="article-content"> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Over the past several seasons, Maryland quarterbacks haven't had much luck with staying healthy. Both <a href="http://www.dbknews.com/2017/09/05/maryland-football-tyrrell-pigrome-acl-injury/">Tyrrell Pigrome</a> and <a href="http://www.dbknews.com/2017/09/26/kasim-hill-maryland-football-acl-injury/">Kasim Hill</a> are out for the season with torn ACLs, so Max Bortenschlager will make his second career start Saturday at Minnesota.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> The Terps haven't had a quarterback start every game in a season since 2006, and his name was Sam Hollenbach. Cheers to you if you actually knew that.</p> </div></div> <div class="pb-feature"> <div id="Mobile_InStory_Top" class="pb-ad-container inline-big-box-300x250 border-bottom-airy" data-mobile-display="true" data-desktop-display="false" data-ad-type="Mobile_InStory_Top" style="display: none;"></div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Bortenschlager is on the list of 15 who have thrown a pass at the position for Maryland since 2007. Here's our definitive ranking of Maryland's top signal-callers through the last decade-plus.</p> </div></div> <div class="pb-feature"> <div id="Desktop_InStory_Top" class="pb-ad-container inline-big-box-300x250 border-bottom-airy" data-mobile-display="false" data-desktop-display="true" data-ad-type="Desktop_InStory_Top" style="display: none;"></div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 15. Josh Portis<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Having to miss two seasons doesn't help someone's resume. Portis began his college career at Florida, appearing in six games in 2005 before transferring to Maryland. After sitting out a year following the transfer, he was suspended for the 2007 season for getting caught cheating on a pop quiz. When he was finally able to take the field in 2008, he spent most of his time as a substitute before transferring again, this time to D-II school California University of Pennsylvania.</p> </div></div> <div class="pb-feature"> <div id="Desktop_InStory_Bottom" class="pb-ad-container inline-big-box-300x250 border-bottom-airy" data-mobile-display="" data-desktop-display="true" data-ad-type="Desktop_InStory_Bottom" style="display: none;"></div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 14. Devin Burns<h4/> </div> </div> <div class="pb-feature"> <div id="Mobile_InStory_Bottom" class="pb-ad-container inline-big-box-300x250 border-bottom-airy" data-mobile-display="true" data-desktop-display="false" data-ad-type="Mobile_InStory_Bottom" style="display: none;"></div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Burns was more of an athlete than a quarterback. He appeared in two games under center before injury, in a 2012 season when the Terps had a carousel at the position. Since he played a lot of his games at wide receiver, there isn't much of an argument for his case at QB.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 13. Daxx Garman<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Another high-profile transfer from a big school, Garman came to College Park from Oklahoma State with high expectations. He started eight games for the Cowboys following an injury to J.W. Walsh and came to Maryland the next year after losing the starting spot back to Mason Rudolph. Unfortunately, he didn't win the quarterback competition for the Terps, either. In 2015, he appeared in just two games, putting up 115 yards and a touchdown.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 12. Shane Cockerille<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> The human Swiss Army knife has seen some time at quarterback when he wasn't at linebacker and fullback. He started the second half against Indiana in 2015, completing 11 passes for 82 yards. Maryland's better off with him on the other side of the ball — he ranked second on the team with 108 tackles in 2016.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 11. Max Bortenschlager<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> We haven't seen much out of Bortenschlager, but granted, he hasn't had much of a chance yet. In his first college start against Nebraska last season, he threw for only 191 yards in a 28-7 loss. Let's hope his performance on Saturday can help him move up this list.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 10. Jordan Steffy<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Steffy saw time on the gridiron throughout his Maryland tenure but wasn't able to pile up the stats. He finished with 92 completions for 933 yards, two touchdowns and eight interceptions.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 9. Jamarr Robinson<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> While Robinson showed some promise when he was behind center, he spent most of his career as a reserve, with two starts. He threw for 808 yards and six touchdowns over two campaigns in College Park.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 8. Shawn Petty<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Originally on the roster as a linebacker, Petty was thrown into the lineup in 2012 after the depth chart was decimated by injuries. He filled in pretty well, throwing for 500 yards, six touchdowns and two interceptions. He then returned to linebacker before transferring to Marshall.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 7. Caleb Rowe<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Although he had a long career in College Park, there weren't too many highlights. Rowe saw time throughout five different seasons but was never able to put it all together, with his 28 interceptions and a completion rate near 50 percent negating 18 passing touchdowns.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 6. Tyrrell Pigrome<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Pigrome came in relief of Perry Hills a few times last year and started the season opener this year against Texas. His second campaign in College Park unfortunately ended early when he went down with a torn ACL in that game. He's shown potential in his young career with the Terps, but he needs to focus on throwing down the field. We haven't seen enough yet.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 5. Kasim Hill<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> We have Hill to thank for securing the win in Austin. The offense didn't miss a step when the freshman came in for Pigrome, and he shined from then on, completing 18 of his 21 passes with two touchdowns and no picks. This season looked a whole lot brighter before he went down against UCF on Saturday.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 4. Danny O’Brien<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Oh, how I wish he was higher on this list. After winning ACC Rookie of the Year in 2010 on the strength of 2,438 passing yards, 22 touchdowns and eight interceptions, O'Brien took a step back his sophomore year before losing the starting job and transferring to Wisconsin. Too bad it never panned out for him in College Park.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 3. Perry Hills<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> While Hills may not have put up the passing numbers that O'Brien did, he stuck with the Terps through multiple injuries. Loyalty and longevity wins. Hills was on the run often at quarterback, so he constantly struggled to stay healthy. From 2012 to 2016 — 2013 was a redshirt year for him — he started 26 games, throwing for 3,887 yards with 29 touchdown passes and 24 interceptions. His senior season was cut short, but he did help the Terps reach the Quick Lane Bowl.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 2. C.J. Brown<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Brown was the epitome of dual threat. He may not have been an all-time great, but he did anything the Terps needed. He finished his four seasons at Maryland with 7,073 total yards — 5,372 through the air, 1,701 on the ground — as well as 33 passing touchdowns, 25 rushing touchdowns and 23 interceptions.</p> </div></div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12"> <h4 class="element element-heading"> 1. Chris Turner<h4/> </div> </div> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-xs-12 col-print-12"> <p class="element element-paragraph"> Turner started 30 games for Maryland from 2007 to 2009, and he was pretty successful during that time. Over his career, he recorded 6,544 passing yards, 33 touchdowns (three of those rushing) and 28 interceptions, and brought the Terps to two bowl games.</p> </div></div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-blank-html" id="fP6TYE1omI4Fsq"> <div> <div style="background-color: #E7E7E7; padding: 10px; width: 100%; text-align: center;font-family: 'Lora'; font-size: 0.7em; text-transform: uppercase; letter-spacing: 1px; border-radius:5px">Please help support our journalism by <a href="http://dbknews.com/donate" target="_blank" style="text-decoration: underline">donating to The Diamondback</a>.</div> </div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-article-big-button-share" id="frzNZC1omI4Fsq"> <div class="social-tools-wrapper-bottom col-md-offset-1 col-md-10 "> <ul class="social-tools-bottom inline"> <li data-sharetype="facebook" class="left facebook"> <a href="#" onclick="ga('CLIENT_TRACKER.send', 'event', 'Big Button Share Click', 'click', 'Facebook'); ga('ARC_TRACKER.send', 'event', 'Big Button Share Click', 'click', 'Facebook'); window.open('https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F','share_facebook','width=658,height=354,scrollbars=no'); return false;" tabindex=_tbidx_> <span class="fa fa-facebook-square">&nbsp;</span><span class="longname">Share on Facebook</span><span class="shortname">Share</span> </a> </li> <li data-sharetype="twitter" class="right twitter"> <a href="#"onclick="ga('CLIENT_TRACKER.send', 'event', 'Big Button Share Click', 'click', 'Twitter'); ga('ARC_TRACKER.send', 'event', 'Big Button Share Click', 'click', 'Twitter'); window.open('https://twitter.com/share?url=http%3A%2F%2Fwww.dbknews.com%2F2017%2F09%2F28%2Fmaryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome%2F&text=Maryland football has had 15 quarterbacks since 2007. We ranked them all.','share_twitter','width=550, height=350, scrollbars=no'); return false;" tabindex=_tbidx_> <span class="fa fa-twitter">&nbsp;</span> <span class="longname">Share on Twitter</span><span class="shortname">Tweet</span> </a> </li> </ul> <div class="clear"></div> </div> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-mailchimp-signup col-lg-12 col-md-12 col-sm-12 col-xs-12" id="f0uQAVFomI4Fsq"> <div class=" with-top-border with-bottom-border col-xs-12 col-sm-10 col-sm-offset-1 col-md-10 col-md-offset-1"> <div class="form-wrapper row"> <div id="mc_embed_signup"> <form action="//dbknews.us9.list-manage.com/subscribe/post?u=589bc6727b2e01217b65a369e&amp;id=bfdcfcc0db" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate> <div id="mc_embed_signup_scroll"> <h2>Get daily headlines delivered to your inbox</h2> <div class="mc-field-group"> <label for="mce-EMAIL">Email Address </label> <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL"> </div> <div id="mce-responses" class="clear"> <div class="response" id="mce-error-response" style="display:none"></div> <div class="response" id="mce-success-response" style="display:none"></div> </div> <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_589bc6727b2e01217b65a369e_bfdcfcc0db" tabindex="-1" value=""></div> <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div> </div> </form> </div></div> </div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-article-related-trending" id="fRH2mO1omI4Fsq"> <div class="row"> <div class=" col-md-offset-1 col-md-10 col-sm-12 col-xs-12 "> <div class="related-trending-menu"> <ul class="sections header-label"> <li class="active"><a>Related</a></li> <li><a>Trending</a></li> </ul> <span class="clearfix"></span> </div> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-related"> <header> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"> <div class="lazy-wrapper"> <img data-original="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/11/13001741/111216FBvsOSU_Rowe_mkm01.jpg&mode=crop&w=600&h=450&q=99" alt="<p>Quarterback Caleb Rowe is tackled inches away from a touchdown in Maryland&#8217;s 62-3 defeat to Ohio State University on Nov. 12, 2016 at Maryland Stadium. (Marquise McKine/The Diamondback)</p>" class="image-lazy" /> </div> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"> <h4>Maryland football has had 15 quarterbacks since 2007. We ranked them all.</h4> <br/> <p class="excerpt">Maryland's quarterbacks have really, really struggled to stay healthy.</p> </a> <div class="byline"> <span class="author"><a href="/author/cannh/" rel="author">Harrison Cann</a></span> <time datetime="2 hours ago"> 2 hours ago </time> </div> </figure> </div> </div> </header> </article> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-related"> <header> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/sophie-giezeman-maryland-field-hockey-holland/"> <div class="lazy-wrapper"> <img data-original="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/09/15225630/092015FHvsNewHampshire_Meharg_mkm01-e1473980200617.jpg&mode=crop&w=600&h=450&q=99" alt="<p>Head coach Missy Meharg walks to sideline after discussing plays with players during the Terps&#8217; 5-2 win against New Hampshire on Sep. 19, 2015.</p>" class="image-lazy" /> </div> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/sophie-giezeman-maryland-field-hockey-holland/"> <h4>Sophie Giezeman left Holland to bolster Maryland field hockey’s defense</h4> <br/> <p class="excerpt">The Terps were "really fortunate" to land the freshman.</p> </a> <div class="byline"> <span class="author"><a href="/author/Scott Gelman/" rel="author">Scott Gelman</a></span> <time datetime="20 hours ago"> 20 hours ago </time> </div> </figure> </div> </div> </header> </article> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-related"> <header class="related-trending-teaser-last"> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/jarena-harmon-maryland-womens-soccer-pittsburgh/"> <div class="lazy-wrapper"> <img data-original="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2017/09/08004604/090717_WSOCvsWM_Harmon_mwr01-e1506553399320.jpg&mode=crop&w=600&h=450&q=99" alt="<p>Forward Jarena Harmon drives to the net during Maryland women’s soccer&#8217;s game against William &#038; Mary on Sept. 7 at Ludwig Field. (Matt Regan/The Diamondback)</p>" class="image-lazy" /> </div> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/jarena-harmon-maryland-womens-soccer-pittsburgh/"> <h4>Transfer Jarena Harmon has sparked Maryland women&#8217;s soccer on offense</h4> <br/> <p class="excerpt">Harmon has scored nine goals with the Terps.</p> </a> <div class="byline"> <span class="author"><a href="/author/whooleys/" rel="author">Sean Whooley</a></span> <time datetime="20 hours ago"> 20 hours ago </time> </div> </figure> </div> </div> </header> </article> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-trending" style="display:none;"> <header> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"> <img src="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/11/13001741/111216FBvsOSU_Rowe_mkm01.jpg&mode=crop&w=600&h=450&q=99" alt="<p>Quarterback Caleb Rowe is tackled inches away from a touchdown in Maryland&#8217;s 62-3 defeat to Ohio State University on Nov. 12, 2016 at Maryland Stadium. (Marquise McKine/The Diamondback)</p>" /> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/maryland-football-quarterback-injury-starter-ranks-kasim-hill-tyrrell-pigrome/"> <h4>Maryland football has had 15 quarterbacks since 2007. We ranked them all.</h4> <p class="excerpt">Maryland's quarterbacks have really, really struggled to stay healthy.</p> </a> <div class="byline"> <span class="author"><a href="/author/cannh/" rel="author">Harrison Cann</a></span> <time datetime="4:36 PM"> 4:36 PM </time> </div> </figure> </div> </div> </header> </article> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-trending" style="display:none;"> <header> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/umd-sga-campus-accountability-bill/"> <img src="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2017/09/14035524/091317_SGAMeeting_map_03-1-of-1.jpg&mode=crop&w=600&h=450&q=99" alt="<p>SGA Meeting in the Stamp student center on Wednesday, September 13, 2017. (Mateo Pacheco/The Diamondback)</p>" /> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/umd-sga-campus-accountability-bill/"> <h4>UMD SGA supports US Senate bill that would increase funding for Title IX offices</h4> <p class="excerpt">The bill would increase funding of university Title IX offices and mandate that offices notify the accuser and the individual accused within 24 hours of the decision to investigate a sexual misconduct complaint.</p> </a> <div class="byline"> <span class="author"><a href="/author/ctaylor/" rel="author">Carly Taylor</a></span> <time datetime="12:21 AM"> 12:21 AM </time> </div> </figure> </div> </div> </header> </article> <article class="related-trending-item related-trending-teaser related-trending-teaser-normal list-trending" style="display:none;"> <header class="related-trending-teaser-last"> <div class="row"> <div class="col-sm-push-8 col-sm-4"> <a href="http://www.dbknews.com/2017/09/28/college-park-election-city-council-district-4/"> <img src="https://images.washingtonpost.com?op=resize&url=https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2017/09/28013900/IMG_1629.JPG.jpeg&mode=crop&w=600&h=450&q=99" alt="<p>Residents and District 4 City Council candidates Dustyn Kujawa and Denise Mitchell discussed various issues during their listening session Wednesday evening at the University Bible Fellowship in College Park (Photo by David Jahng/For The Diamondback)</p>" /> </a> </div> <div class="col-sm-pull-4 col-sm-8"> <figure> <a href="http://www.dbknews.com/2017/09/28/college-park-election-city-council-district-4/"> <h4>Two College Park City Council candidates are campaigning together</h4> <p class="excerpt">Attendees discussed various issues with the candidates during the session including development, traffic and parking.</p> </a> <div class="byline"> <span class="author"><a href="/author/freelancereporter/" rel="author">Freelance Reporter</a></span> <time datetime="12:14 AM"> 12:14 AM </time> </div> </figure> </div> </div> </header> </article> </div> </div> <div class="clear"></div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 pb-feature pb-layout-item pb-f-ads-dfp-leaderboard-728x90 col-xs-12" id="f9V2OU1omI4Fsq"> <div id="Banner_E" class="pb-ad-container leaderboard-728x90 border-bottom-hairline" data-ad-type="Banner_E" style="display: none; "></div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 pb-feature pb-layout-item pb-f-article-comments-disqus col-sm-12 col-xs-12" id="f0SqcGpomI4Fsq"> <div class="disqus-header col-md-offset-1 col-md-10 col-sm-12 col-xs-12 "><h2 class="header-label">Comments</h2></div> <div id="disqus_thread" class=" col-md-offset-1 col-md-10 col-sm-12 col-xs-12 disqus-container" data-disqus-id="thediamondback"></div> <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript> <div class="clear"></div> </div> </div> <div class="col-md-4 col-sm-12 col-xs-12"> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 pb-feature pb-layout-item pb-f-ads-dfp-big-box-300x250 col-xs-12" id="f0jk2uuomI4Fsq"> <div id="Banner_B" class="pb-ad-container big-box-300x250 border-bottom-hairline" data-mobile-display="false" data-desktop-display="true" data-ad-type="Banner_B" style="display: none;"></div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 pb-feature pb-layout-item pb-f-ads-dfp-halfpage-300x600 col-sm-12 col-xs-12" id="fvAjmn1omI4Fsq"> <div id="Banner_C" class="pb-ad-container halfpage-300x600 border-bottom-hairline" data-ad-type="Banner_C" style="display: none;"></div> </div> </div> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-ads-dfp-mobile-interstitial-300x450" id="fIXRCk2omI4Fsq"> <div class="background-div" style="width: 5000px; position: absolute; top: -1000px; left: -1000px; height: 5000px; background-color: white; opacity: .8; z-index:-1;display:none;"> </div> <div id="interstitial_Mobile" class="pb-ad-container interstitial-300x450" data-ad-type="interstitial_Mobile" style="display:none;"></div> <img class="modal-ad-close" src="/pb/resources/assets/img/modal_close_button.png"/> </div> <div class="wrapper clearfix col-lg-12 col-md-12 pb-feature pb-layout-item pb-f-ads-dfp-wallpaper-interstitial col-sm-12 col-xs-12" id="fMw8d12omI4Fsq"> <div class="background-div" style="width: 5000px; position: absolute; top: -1000px; left: -1000px; height: 5000px; background-color: white; opacity: .8; z-index:-1;display:none;"> </div> <div id="interstitial_Desktop" class="pb-ad-container desktop-interstitial" data-ad-type="interstitial_Desktop" style="display:none;"></div> <img class="modal-ad-close" src="/pb/resources/assets/img/modal_close_button.png"/> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-blank-html col-sm-6 col-lg-4 col-xs-12 col-md-4" id="fGJVOw1omI4Fsq"> <div> <div><h2 class="header-label">DBK Top Stories</h2><center><iframe src="//dbknews.friends2follow.com/f2f/widget/html/socialstack/50/0/6/120/1/2/0/7" frameborder="0" height="600" width="300" scrolling="no"></iframe></center></div> </div> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-blank-html col-sm-6 col-lg-4 col-xs-12 col-md-4" id="f7BY8e2omI4Fsq"> <div> <div style="display: none;"><h2 class="header-label">DBK Connect</h2><center><iframe src="http://dbknews.friends2follow.com/f2f/widget/html/socialstack/46/0/9/120/1/2/1/7?equalheights=1" frameborder="0" height="600" width="300" scrolling="no"></iframe></center></div> </div> </div> </div> </section> <section id="bottom" class=""> <div class="pb-container"> <div class="wrapper clearfix col-lg-12 col-md-12 col-sm-12 col-xs-12 pb-feature pb-layout-item pb-f-ads-dfp-mobile-footer-300x50" id="f0xHQ7PomI4Fsq"> <div id="Mobile_Footer" class="mobile-fixed pb-ad-container-mobile mobile-footer-300x50 border-bottom-hairline" data-ad-type="Mobile_Footer" style="display: none;"></div> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-ads-dfp-ad-script" id="f0loGCBomI4Fsq"> <script>window.googletag.cmd.push(function(){googletag.pubads().setCentering(!0);googletag.pubads().enableAsyncRendering();googletag.enableServices()});</script> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fvcUAi1omI4Fsq"> <footer> <div class="footer-row-1 row"> <ul class="footer-links col-lg-12 col-md-12 col-sm-12 col-xs-12"> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/about/">About</a> </li> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/find-a-paper/">Find A Paper</a> </li> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/policies/">Policies</a> </li> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/advertising/">Advertising</a> </li> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/join-the-diamondback/">Jobs</a> </li> <li class='footer-nav '> <a class='footer-nav-item header-label' href="http://www.dbknews.com/contact-us/">Contact Us</a> </li> </ul> </div> <div class="footer-row-2 row"> <aside class="header-label footer-nav-item company-name col-lg-6 col-md-6 col-sm-12 col-xs-12">&#169; 2017 The Diamondback</aside> <aside class="header-label powered-by-container col-lg-6 col-md-6 col-sm-12 col-xs-12"> <img class="powered-by" src="/pb/resources/assets/img/poweredby_white.png" alt="Powered by Washington Post Arc Publishing"/> </aside> </div> </footer> </div> <div class="pb-container"> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-ads-dfp-ad-script" id="fE00Zb2omI4Fsq"> <script>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</script> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-ad-block-detection" id="f0gY7Q7omI4Fsq"> <div id="detected" style="display:none;"> <div class="background-div" style="width: 5000px; position: absolute; top: -1000px; left: -1000px; height: 5000px; background-color: white; opacity: .8; z-index:-1;"> </div> <a href="http://www.dbknews.com/donate/"><img id="detectedImg" src="https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2016/08/09191258/Adblocker_revised-e1470769991188.jpg" data-image="true"/></a> <img class="modal-close" src="/pb/resources/assets/img/modal_close_button.png"/> </div> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-blank-html col-sm-6 col-lg-4 col-xs-12 col-md-4" id="fC3VDr1omI4Fsq"> <div> <style>#donationad{position:fixed;bottom:0;left:40px;width:250px;height:150px;z-index:999;display:none}#donationad.hide{display:none}.closebutton{position:relative;top:20px;left:230px;cursor:pointer}.closebutton img{width:30px;height:auto;opacity:1.0}</style> <script>$(document).ready(function(){$(".closebutton").click(function(){document.getElementById("donationad").style.display="none";-1==document.cookie.indexOf("visited\x3d",0)&&(document.cookie="visited\x3d1;max-age\x3d360;path\x3d/")})});</script> <div id="donationad"> <div class="closebutton"> <img src="http://www.dbknews.com/pb/resources/assets/img/modal_close_button.png"> </div> <a href="https://www1.ticketmaster.com/event/15005327A79E2F1A" target="_blank"> <img src="https://s3.amazonaws.com/wapopartners.com/dbknews-wp/wp-content/uploads/2017/09/23053009/john-mulaney-250x150.gif"> </a> </div> <script>var cookie=document.cookie;console.log("Checking cookie");if(-1==cookie.indexOf("visited\x3d",0)){var element=document.getElementById("donationad");element.style.display="block"};</script> </div> </div> <div class="wrapper clearfix pb-feature pb-layout-item pb-f-global-blank-html col-sm-6 col-lg-4 col-xs-12 col-md-4" id="fjOtN81HGK4Fsq"> <div> <script>!function(){var a=document.createElement("script");a.type="text/javascript";a.async=!0;a.src="//www.rtb123.com/tags/773F3C17-7C67-20A7-40A0-F1BBB5264072/btp.js";var b=document.getElementsByTagName("head")[0];b?b.appendChild(a,b):(b=document.getElementsByTagName("script")[0]).parentNode.insertBefore(a,b)}();</script> </div> </div> </div> </section> <div class="pb-container"> </div></div> <script src="//f.vimeocdn.com/js/froogaloop2.min.js"></script> <script>var pb_global={pageName:"article",pageId:"rbKOI52RYMmxwq",contextPath:"/pb",isAdmin:!1,layoutEngineName:"",environment:"",resourceToken:""};</script> <script src="/pb/gr/c/default/rbKOI52RYMmxwq/js/7bb01e7511.js?_=4ec21"></script> <script src="/pb/gr/c/default/rbKOI52RYMmxwq/footjs/da39a3ee5e.js?_=34eae"></script> <script src="//maxcdn.bootstrapcdn.com/bootstrap/3.3.4/js/bootstrap.min.js"></script> <script src="/pb/gr/c/default/rbKOI52RYMmxwq/footjs/a10acf3d0b.js?_=34eae"></script> <script src="https://www.youtube.com/iframe_api"></script> <script src="/pb/gr/c/default/rbKOI52RYMmxwq/footjs/11f3bebf7c.js?_=34eae"></script> <script src="/pb/gr/p/default/rbKOI52RYMmxwq/render.js?_=8c911"></script> <script>var _sf_async_config={uid:20209,domain:"diamondbackonline.com",useCanonical:!0};(function(){function b(){window._sf_endpt=(new Date).getTime();var a=document.createElement("script");a.setAttribute("language","javascript");a.setAttribute("type","text/javascript");a.setAttribute("src","//static.chartbeat.com/js/chartbeat.js");document.body.appendChild(a)}var c=window.onload;window.onload="function"!=typeof window.onload?b:function(){c();b()}})();</script> <script>var _sf_async_config=_sf_async_config||{};_sf_async_config.uid=63174;_sf_async_config.domain="dbknews.com";_sf_async_config.useCanonical=!0;(function(){function b(){window._sf_endpt=(new Date).getTime();var a=document.createElement("script");a.setAttribute("language","javascript");a.setAttribute("type","text/javascript");a.setAttribute("src","//static.chartbeat.com/js/chartbeat.js");document.body.appendChild(a)}var c=window.onload;window.onload="function"!=typeof window.onload?b:function(){c();b()}})();</script> <noscript> <div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-B24x2HZw3TMWb.gif" border="0" height="1" width="1" alt="Quantcast"/> </div> </noscript> <script id='dsq-count-scr' src='//thediamondback.disqus.com/count.js' async></script> <script>jQuery(function(){jQuery.scrollDepth()});</script> <script>var cb=function(){var a=document.createElement("link");a.rel="stylesheet";a.href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap-theme.min.css";var b=$("head")[0];$(b).append(a)};window.addEventListener("load",cb);</script> </body> </html>